gameLauncher.exe and .swos-port-Release.exe

More
2 months 2 weeks ago - 2 months 2 weeks ago #144242 by starwindz
All CLI(Command Line Interface) Options for SWOS Port Executable

*Gameplay
--game-style=0|1|2
0: PC gameplay style
1: Amiga gameplay style
2: Moon soccer style

--improved-cpu-tactics=0|1
0: Original
1: Mozg's improved tactics

--super-power-cpu-mode=0|1
0: Disabled
1: Enabled

*Video
--screen-mode=0|1|2
0: Original PC DOS screen
1: Original Amiga screen
2: Widescreen

--window-width=nnn
nnn: Window width

--window-height=nnn
nnn: Window height

--window-mode=1|2
1: Windowed mode
2: Full screen mode

--monitor-id=0|1|2
0: Monitor display number 0 (First display)
1: Monitor display number 1 (Second display)
2: Monitor display number 2 (Third display)

*Team Database & Career Mode Setting
--season-year=nnnn
nnnn: Start year of game season
(if nnnn >= 2019, some country and league names changed:
TAIWAN -> CHINA, TAIWANESE -> CHINENSE,
GHANA -> EGYPT, GHANA -> EGYPT)

--career-crash-fix=abcdefg
(1:On, 0:Off)
a: TeamNumFix (Fix up number of teams from team.xxx)
b: MonthFix ("Jan to Dec" or "Jul to Jun")
c: EachMatchFix (leagues > 12 -> num. of match = 2)
d: GreekFix (Greek league fix)
e: Reserved
f: Reserved
g: Reserved
* --career-crash-fix=1111111 recommended

--always-points-per-win-3=0|1
0: Points per win for all leagues is not always 3
(Exception: Slovakia, Slovenia, Bolivia and Brazil)
1: Points per win for all leagues is 3

*Skip and Delay
--no-intro=0|1 (Original Zlatko's version)
0: Disabled
1: Enabled

--no-image-reels=0|1 (Original Zlatko's version)
0: Disabled
1: Enabled

--no-load-pause=0|1 (Original Zlatko's version)
0: Disabled
1: Enabled

*Additional Display
--new-scoreboard=0|1|2|3|4
0: Original
1: New scoreboard (Left-Top)
2: New scoreboard (Right-Top)
3: New scoreboard (Left-Bottom)
4: New scoreboard (Right-Bottom)

--alpha-blending-menu=nn
nn: 00 to 99 - Opacity of menu transparency (%)

--flashing-menu-cursor=0|1|2|3
0: Original
1: No flashing
2: Smooth flashing (Fast)
3: Smooth flashing (Slow)

--mouse-cursor=0|1|2
0: Windows style
1: Amiga Workbench 2.04 style
2: Amiga Workbench 1.X style

--new-show-result=0|1
0: Original
1: Removed left and right spaces in the widescreen mode

--remove-darken-banner=0|1
0: Enable darken banner for new scoreboard
1: Disable darken banner for new scoreboard

--improved-pitch-palette=0|1
0: Enable
1: Disable

*Advanced Video
--screen-enhancement=0|1
0: Software scaler
1: OpenGL shader

--filter=0|1|2|3|4|5|6|7|8|9
(Software pixel scaler)
0: None
1: Simple2x
2: Scale2x
3: Scale3x
4: LQ2x
5: LQ3x
6: HQ2x
7: HQ3x
8: 2xBRZ
9: 3xBRZ

--shader-program=0|1|2
(OpenGL shader)
0: CRT-Simple
1: CRT-Lottes
2: CRT-Geom
Last edit: 2 months 2 weeks ago by starwindz.
The following user(s) said Thank You: dovellonsky

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #144243 by dovellonsky
Many many thanks !

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago - 2 months 2 weeks ago #144244 by dovellonsky
strangely there is this problem that does NOT occur with the BuiltIn Minilauncher.

File Attachment:

Windows Toolbar :(
This is my CMD
--game-style=1 --improved-cpu-tactics=0 --screen-mode=1 --window-mode=0 --window-width=1280 --window-height=1024 --new-scoreboard=1 --flashing-menu-cursor=0 --mouse-cursor=2 --screen-enhancement=1 --shader-program=2

I believe that the command WINDOWS MODE = 0, has no effect in the game , work with ALt+Enter
Last edit: 2 months 2 weeks ago by dovellonsky.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago - 2 months 2 weeks ago #144247 by starwindz
what is your actual screen resolution of 4:3 monitor PC?
and can you change following numbers(1280, 1024) to actual screen resolution?
--window-width=1280 --window-height=1024

plz let me know the result of above modification on this forum or discord

(P.S.) and one more thing. plz add following cli option to prevent crash in the career mode
--career-crash-fix=1111111


dovellonsky wrote: strangely there is this problem that does NOT occur with the BuiltIn Minilauncher.


Windows Toolbar :(
This is my CMD
--game-style=1 --improved-cpu-tactics=0 --screen-mode=1 --window-mode=0 --window-width=1280 --window-height=1024 --new-scoreboard=1 --flashing-menu-cursor=0 --mouse-cursor=2 --screen-enhancement=1 --shader-program=2

I believe that the command WINDOWS MODE = 0, has no effect in the game , work with ALt+Enter

Last edit: 2 months 2 weeks ago by starwindz.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #144248 by dovellonsky
Yep , monitor is 1280 x 1024 ( 4:3 )
I also tried to change the resolution using the one preset by the MiniLauncher, but the result doesn't change,
I also tried to change the resolution using the one preset by the MiniLauncher, but the result doesn't change,

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #144249 by starwindz
in the launcher, it works fine (no taskbar)?
can you show me the settings of launcher such as screenshot of launcher?

dovellonsky wrote: Yep , monitor is 1280 x 1024 ( 4:3 )
I also tried to change the resolution using the one preset by the MiniLauncher, but the result doesn't change,

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #144250 by dovellonsky
now I'm at work, as soon as I get home I'll give you a screen and try cmd 11111 too
Thankyou for support

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #144251 by dovellonsky


this is 800x 600 setting
--game-style=1 --improved-cpu-tactics=0 --screen-mode=1 --window-mode=0 --window-width=800 --window-height=600 --new-scoreboard=1 --flashing-menu-cursor=0 --mouse-cursor=2 --screen-enhancement=1 --shader-program=2

File Attachment:

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #144252 by dovellonsky
In the launcher work perfect

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #144253 by starwindz
definitely cli option issue
will do thorough check and find the solution

Please Log in or Create an account to join the conversation.

Time to create page: 0.294 seconds
Powered by Kunena Forum